Error Message on Physical device – The resource loader cache doesn’t have loaded MUI entry.

Error Message on Physical device – The resource loader cache doesn’t have loaded MUI entry.

  • Title

    Error Message on physical device when connecting to HVD – The resource loader cache doesn’t have loaded MUI entry. 

  • Description

    Active Administrator - The resource loader cache doesn't have loaded MUI entry

    The problem can occur on 64-bit versions of Windows Vista and Windows 7 when attempting any of the following operations on Active Directory (AD) objects:


     

    1. Create computer

    2. Create user

    3. Create group

    4. Create printer

    5. Create shared folder

    6. View properties of user, computer, or group objects.


     

  • Cause

    When the Microsoft Remote Server Administration Tools (RSAT) are installed on 64-bit versions of Windows Vista or Windows 7, the files adprop.dll.mui and dsadmin.dll.mui are not installed into the correct location.  
  • Resolution

    Download the 32-bit version of the Microsoft Remote Server Administration Tools (RSAT) to a local directory on the 64-bit Windows Vista or Windows 7 computer where the Active Administrator Console is installed (e.g., “C:\MSUFolder”):


    Windows Vista

    http://www.microsoft.com/en-us/download/details.aspx?id=21090

     

    Windows 7

    http://www.microsoft.com/downloads/details.aspx?FamilyID=7D2F6AD7-656B-4313-A005-4E344E43997D&displaylang=en



    NOTE: The 32-bit version of the Windows 7 RSAT package is used in the examples below.

    At a command prompt, use the Expand command to extract the .cab file from the Microsoft Update Standalone Package (MSU) package. For example, if the RSAT package was saved to the folder “C:\MSUFolder” then type the following command:

     

    expand -F:* x86fre_GRMRSAT_MSU.msu c:\MSUFolder 

     

    Right click open image to view full size

    Click To See Full Image.

     

    There will be two (2) CAB files in the expansion directory, one with a KB article in the title and one named WSUSSCAN.CAB.



    Right click open image to view full size

    Click To See Full Image.



     

    Use the Expand command to decompress the .cab file with the KB article in its title.
    Continuing with the example above, if the RSAT package was extracted to the folder “C:\MSUFolder” then type the following command:

    expand Windows6.1-KB958830-x86.cab -F:adprop.dll.mui C:\MSUFolder

     


    Right click open image to view full size

    Click To See Full Image.

     

    After executing the command, the subfolders that are created in the expansion directory correspond to different language versions. Locate the subfolder for language version of the operating system on which the Active Administrator Console is installed – for this example, the language is American English (“_en-us_”):




    Right click open image to view full size

    Click To See Full Image.

     

    Repeat step #4 to extract the file dsadmin.dll.mui. Following the example above, the command would be:

     

    expand Windows6.1-KB958830-x86.cab -F:dsadmin.dll.mui C:\MSUFolder

    In the illustration below, all subfolders for non-US English language versions have been omitted for clarity.


    Right click open image to view full size

    Click To See Full Image.

     

    Copy the files adprop.dll.mui and dsadmin.dll.mui to the folder “C:\Windows\SysWOW64\en-US”.

    If the language version of the operating system is different than what is referenced in the examples above, the files should be copied into the appropriate language resource directory.

    Once the files are in place, operations on Active Directory objects can be accomplished within the Active Administrator Console.

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